Link

Installing Optic

Prerequisites

Install the Optic CLI from npm or yarn. The CLI allows you to run Optic in your local development environment.

yarn global add @useoptic/cli@^8
npm install @useoptic/cli@^8 -g

Note: Install Optic globally is required.

If you have trouble getting Optic installed, please open an issue on GitHub


Add Optic to your Project

After installing the CLI, it’s time to add Optic to your API project. There are guides available for most languages and API frameworks: